CERCA
PER MODELLO
FullScreen Chatbox! :)

Utente del giorno: Stahl con ben 19 Thanks ricevuti nelle ultime 24 ore
Utente della settimana: Stahl con ben 88 Thanks ricevuti negli ultimi sette giorni
Utente del mese: Stahl con ben 466 Thanks ricevuti nell'ultimo mese

Visualizzazione dei risultati da 1 a 2 su 2
Discussione:

Impostare display output

Se questa discussione ti è stata utile, ti preghiamo di lasciare un messaggio di feedback in modo che possa essere preziosa in futuro anche per altri utenti come te!
  1. #1
    Baby Droid L'avatar di saburosakai


    Registrato dal
    May 2013
    Messaggi
    6

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Question

    Impostare display output

    Hola! Ho comprato da un mesetto ormai, la developer board Miniand Hackberry A10. Che dire è un bel giocattolino tenendo conto del rapporto qualità prezzo senza contare il fatto che permette anche di usare linux da SD.

    Purtroppo i miei tentavi di utilizzare questa scheda con il mio vecchio televisore a tubo catodico non hanno avuto un grande successo o meglio...se avvio Android e da lì scelgo come output video "PAL", non appena collego il cavo RCA --> SCART alla TV funziona tutto. Il problema è che ogni volta che spengo la scheda mi perde il settaggio, quindi dovrei a ogni accensione andare in "Settings" e scegliere PAL (cosa non facile da fare senza altri schermi).

    Tramite ADB mi sono scaricato il file "script.bin" dalla "nanda", e ho provato a modificarlo in modo che l'uscita video fosse settata per TV PAL di default.
    Quindi alla voce:
    codice:
    [disp_init]
    disp_init_enable = 1
    disp_mode = 0
    screen0_output_type = 3
    screen0_output_mode = 5
    screen1_output_type = 1
    screen1_output_mode = 4
    fb0_framebuffer_num = 2
    fb0_format = 10
    fb0_pixel_sequence = 0
    fb0_scaler_mode_enable = 1
    fb1_framebuffer_num = 2
    fb1_format = 10
    fb1_pixel_sequence = 0
    fb1_scaler_mode_enable = 1
    Ho modificato i campi "screen0_output_type = 2" e "screen0_output_mode = 11" come indicato qui "URL" linux-sunxi.org/Fex_Guide#tv_configuration "URL" , ma ahimè, anche se la TV da qualche strano segnale, complessivamente non mi fa vedere nulla.

    Ho visto che sulla memoria interna della scheda c'è anche un file che si chiama "boot.ini" e contiene queste stringhe:
    codice:
    [system]
    start_os_name = linux
    timeout       = -1
    display_device= -1
    display_mode  = 0
    erase_flash   = 1
    [linux]
    Il problema è che non ho idea di come modificarle per ottenere l'output in VGA PAL.

    Qualcuno è riuscito a configurare l'Hackberry per usarlo sulla TV?
    Secondo voi può essere dovuto a un'errata configurazione del framebuffer o della pixel sequence?

    Ogni idea volta a risolvere questo problema è ben accetta, anche se si tratta di andare a pacioccare il sistema android
    Ultima modifica di saburosakai; 03-05-13 alle 22:10

  2.  
  3. #2
    Baby Droid L'avatar di saburosakai


    Registrato dal
    May 2013
    Messaggi
    6

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Risolto ecco la configurazione corretta:

    [disp_init]
    disp_init_enable = 1
    disp_mode = 2
    screen0_output_type = 3
    screen0_output_mode = 5
    screen1_output_type = 4
    screen1_output_mode = 4
    fb0_framebuffer_num = 2
    fb0_format = 10
    fb0_pixel_sequence = 0
    fb0_scaler_mode_enable = 1
    fb1_framebuffer_num = 2
    fb1_format = 10
    fb1_pixel_sequence = 3
    fb1_scaler_mode_enable = 1

    Ho anche modificato nel boot.ini "erase_flash = 1" in "erase_flash = 0".
    Il cavo video RCA va inserito nel secondo jack di Hackberry.

Tag per questa discussione

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire risposte
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Torna su
Privacy Policy