CERCA
PER MODELLO
FullScreen Chatbox! :)

Utente del giorno: Stahl con ben 23 Thanks ricevuti nelle ultime 24 ore
Utente della settimana: Stahl con ben 115 Thanks ricevuti negli ultimi sette giorni
Utente del mese: Stahl con ben 454 Thanks ricevuti nell'ultimo mese

Pagina 3 di 6 primaprima 12345 ... ultimoultimo
Ultima pagina
Visualizzazione dei risultati da 21 a 30 su 52
Discussione:

Iniziare a programmare per android

Se questa discussione ti è stata utile, ti preghiamo di lasciare un messaggio di feedback in modo che possa essere preziosa in futuro anche per altri utenti come te!
  1. #21
    Androidiano L'avatar di Spremuta


    Registrato dal
    Aug 2009
    Messaggi
    192

    Ringraziamenti
    15
    Ringraziato 7 volte in 7 Posts
    Predefinito

    Quote Originariamente inviato da Androsauro Visualizza il messaggio
    eheh se avessi vista sarei già passato a qualcos'altro. No, windows XP home edition.
    Per quanto concerne linux, come faccio a sapere se scaricare la versione di eclipse da 32bit o da 64bit?

    Inoltre adesso sono andato sul sito di eclipse per scaricarlo, ma il link per la versione di linux non va, ora provo da linea di comando...

    Niente da fare neanche qui, mi dà un sacco di errori del tipo 404 not found, probabilmente perchè uso una versione vecchiotta (la 7.04) di ubuntu.
    Ma sei sicuro che la connessione ti funziona?

  2.  
  3. #22
    Androidiano


    Registrato dal
    Sep 2009
    Messaggi
    114

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Quote Originariamente inviato da Spremuta Visualizza il messaggio
    Ma sei sicuro che la connessione ti funziona?
    E come avrei fatto a postare?

    Comunque sono riuscito a installarlo su windows (alla fine penso bastasse riavviare... tipico) il problema adesso è che non sono sicuro se ha memorizzato bene il path della sdk di android.
    Domani provo a fare un "hello world" e se funziona dovrebbe essere andato tutto liscio. Vero?

  4. #23
    Androidiano VIP


    Registrato dal
    Sep 2009
    Messaggi
    1,574

    Ringraziamenti
    5
    Ringraziato 146 volte in 132 Posts
    Predefinito

    Per Linux, ti sarebbe convenuto aggiornare Ubuntu dato che nelle ultime versioni Eclipse è incluso nei repository ufficiali, quindi lo avresti installato rapidamente da Aggiungi/Rimuovi software (se usi Gnome)

  5. #24
    Androidiano L'avatar di Spremuta


    Registrato dal
    Aug 2009
    Messaggi
    192

    Ringraziamenti
    15
    Ringraziato 7 volte in 7 Posts
    Predefinito

    Quote Originariamente inviato da Androsauro Visualizza il messaggio
    E come avrei fatto a postare?

    ovviamente intendevo su ubuntu, dove mi pare di capire avessi problemi...
    - Xiaomi Mi4 64 GB - ex GalaxyNexus

  6. #25
    Androidiano


    Registrato dal
    Sep 2009
    Messaggi
    114

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Quote Originariamente inviato da LoZeno Visualizza il messaggio
    Per Linux, ti sarebbe convenuto aggiornare Ubuntu dato che nelle ultime versioni Eclipse è incluso nei repository ufficiali, quindi lo avresti installato rapidamente da Aggiungi/Rimuovi software (se usi Gnome)
    Hai ragione da vendere, purtroppo quando era il momento di passare alla 7.10 non ne sentivo il bisogno, inoltre ho sempre avuto dei problemi con la wireless passando da una versione all'altra. Tu conosci un modo per fare l'upgrade ora?

    Quote Originariamente inviato da Spremuta Visualizza il messaggio
    ovviamente intendevo su ubuntu, dove mi pare di capire avessi problemi...
    Sì, i problemi ci sono tutt'ora, ma stavo provando a scaricare eclipse proprio mentre scrivevo. comunque mi resta windows, dove sembra andare tutto per il meglio, a parte il fatto che il mio pc è così lento che mi basta aprire eclipse e una pagina web, perchè l'emulatore rallenti tutto miseramente.
    Tralasciando le mie sfortune, vorrei chiedervi se il comando che si trova nella guida per creare l'hello world, va dato solo la prima volta oppure tutte le volte che si vuole programmare con l'sdk di android... Ecco il comando:
    android create avd --target 2 --name my_avd

  7. #26
    Androidiano VIP


    Registrato dal
    Sep 2009
    Messaggi
    1,574

    Ringraziamenti
    5
    Ringraziato 146 volte in 132 Posts
    Predefinito

    Quote Originariamente inviato da Androsauro Visualizza il messaggio
    Hai ragione da vendere, purtroppo quando era il momento di passare alla 7.10 non ne sentivo il bisogno, inoltre ho sempre avuto dei problemi con la wireless passando da una versione all'altra. Tu conosci un modo per fare l'upgrade ora?
    Il modo più semplice è scaricare (tramite torrent magari, così non hai problemi di interruzioni di download ed è più veloce) l'ISO del LiveCD di Ubuntu, farlo partire e scegliere "Installazione su Disco"; a quel punto ti chiede se vuoi aggiornare il sistema già presente, o fare un'installazione ex-novo.

    Se hai paura di non trovare drivers per qualche scheda del tuo computer, scarica Linux Mint invece di Ubuntu: Mint è una "fork" di Ubuntu, in cui vengono di default inseriti nell'installazione anche drivers e software non-Open e non-Free, come ad esempio codec per gli mp3 (invece che solo gli OggVorbis) e vari drivers proprietari per schede wireless. Con Ubuntu si trovano lo stesso, ma in genere bisogna "scovare" i repository ed aggiungerli al gestore di pacchetti.

    Io non sono un "ubuntiano", la mia distro di scelta è Fedora, ma dal poco che ricordo per l'installazione e l'aggiornamento le due distro hanno operato scelte simili se non identiche.

  8. #27
    Baby Droid


    Registrato dal
    Sep 2009
    Messaggi
    23

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Io ormai uso linux da una vita e posso dire che ubuntu 9.04 (l'ultima versione, la prossima esce intorno a metà-fine ottobre) supporta molte schede wifi sia interne, sia esterne, sia usb senza troppi problemi. In caso scaricati una live da ubuntu e provala così vedi sa la wireless va ^^.
    Imho consiglio ubuntu rispetto alle derivate solo perché la canonical fa sempre (o quasi) i lavori fatti bene e di solito si rischia un po' di instabilità usando distro che derivano da altre.

    Pure io su windows (nel mio caso vista) ho qualche problemino a far andare l'ide + l'emulatore agganciando i programmi, però su linux in neanche 15 minuti ho preparato tutto e funzia molto bene.

    Ciau !

  9. #28
    Androidiano


    Registrato dal
    Sep 2009
    Messaggi
    114

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Dunque... ho cambiato idea, sto provando a preparare la mia partizione debian per programmare con android.
    Ho già scaricato eclipse, ma quando lo faccio partire esce questo messaggio: Version 1.4.2 of the JVM is not suitable for this product. Version: 1.5 or greater is required., in pratica dice che la mia jvm 1.4.2 è da aggiornare.
    Ho già provato in vari modi, primo fra tutti andando nel sito della sun e scaricandola direttamente da lì, ma finora non è cambiato nulla nel messaggio iniziale datomi appena dopo l'apertura di eclipse.
    Voi, senza avere nessuna ulteriore informazione cosa fareste? Cioè, come primo approccio, cosa fareste?

    Poi magari vi dico se ho già provato i vostri suggerimenti e con che esiti.
    Ultima modifica di Androsauro; 02-10-09 alle 17:45

  10. #29
    Senior Droid L'avatar di mbiza


    Registrato dal
    May 2009
    Messaggi
    648
    Smartphone
    G1, SGS2

    Ringraziamenti
    8
    Ringraziato 59 volte in 45 Posts
    Predefinito

    se hai scaricato la versione nuova della jvm e l'hai anche installata ora devi dire al sistema operativo quale versione usare.
    quindi da root dai sul terminale:
    codice:
    update-alternatives --config java
    e ti uscirà una cosa simile a questa
    codice:
      0            /usr/lib/jvm/java-gcj/jre/bin/java         1043      auto mode
      1            /usr/bin/gij-4.3                           43        manual mode
      2            /usr/lib/jvm/java-1.5.0-sun/jre/bin/java   53        manual mode
    * 3            /usr/lib/jvm/java-6-sun/jre/bin/java       63        manual mode
      4            /usr/lib/jvm/java-gcj/jre/bin/java         1043      manual mode
    
    Press enter to keep the current choice[*], or type selection number:
    scrivi il numero corrispondente a java-6-sun e dai Invio.
    Comunque se sei su debian ti consiglio sempre di installare questi pacchetti con apt, in questo caso
    codice:
    apt-get install sun-java6-jdk
    e poi fai il procedimento sopra

    questi sono i repository da mettere in /etc/apt/sources.list
    codice:
    ### Debian Ufficiale -- etch
    deb ftp://ftp.it.debian.org/debian/ etch main contrib non-free 
    
    ### Debian Ufficiale -- etch Sicurezza
    deb http://security.debian.org/ etch main contrib non-free
    edit: occhio che avevo scritto male i repo!! aggiorna!
    Ultima modifica di mbiza; 02-10-09 alle 18:34

    Phone: Black SGS2
    Rom:...

  11. #30
    Baby Droid


    Registrato dal
    Sep 2009
    Messaggi
    23

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Aggiungo solo che quei repository sono per debian etch. Per l'ultima debian stable ( la lenny ) basta cambiare etch in lenny.

    Ciao !

Pagina 3 di 6 primaprima 12345 ... ultimoultimo
Ultima pagina

Discussioni simili

  1. Vorrei iniziare...
    Da upkins nel forum Iniziare a programmare Android
    Risposte: 7
    Ultimo messaggio: 17-10-11, 02:38
  2. Iniziare a creare ROM
    Da federico nel forum Risorse Utili
    Risposte: 0
    Ultimo messaggio: 04-11-09, 22:57
  3. Iniziare con htc
    Da SebaLvga nel forum HTC Magic
    Risposte: 2
    Ultimo messaggio: 02-10-09, 20:07
  4. iniziare da.. zero!
    Da federico nel forum Risorse Utili
    Risposte: 3
    Ultimo messaggio: 30-03-09, 09:59

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire risposte
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Torna su
Privacy Policy