CERCA
PER MODELLO
FullScreen Chatbox! :)

Utente del giorno: Stahl con ben 12 Thanks ricevuti nelle ultime 24 ore
Utente della settimana: Stahl con ben 123 Thanks ricevuti negli ultimi sette giorni
Utente del mese: Stahl con ben 434 Thanks ricevuti nell'ultimo mese

Visualizzazione dei risultati da 1 a 7 su 7
Discussione:

Problema webview con sito statico su JB

  1. #1
    Senior Droid


    Registrato dal
    Aug 2010
    Messaggi
    523
    Smartphone
    N6 - S4 Mini - N9 LTE

    Ringraziamenti
    29
    Ringraziato 19 volte in 18 Posts
    Predefinito

    Problema webview con sito statico su JB

    Ciao a tutti.
    Chiedo una piccola consulenza.
    Ho creato un'app con un form di login nativo (nel senso che ho creato una view con i dati di utenza e password da inserire).
    Oltre a questo ho inserito 2 bottoni:

    • il primo bottone serve per la login all'applicazione web (e fa partire una webview) gestita correttamente con Async
    • il secondo bottone serve per aprire un altro sito web statico (e parte sempre la webview con un altro url ma senza Async dato che non ci parametri da passare


    Il problema nasce dal fatto che se lancio l'applicazione su Gingerbread, non ho nessun problema con nessun bottone, ma da ICS in su, il 2 bottone instanzia correttamente la webview ma la pagina rimane bianca.
    Ho gi verificato che la pagina statica non contiene codice javascript per cui il problema non quello e il logcat non scrive assolutamente nulla in merito per cui non riesco a capire dove sbaglio.
    Ho cercato ovunque (anche su stackoverflow) ma non c' nessuno che ha avuto lo stesso problema.

    L'applicazione compilato con l'ultima versione dell'API (17): mi manca solo questo e poi potr pubblicare l'app su Play Store.

    Se avete bisogno di ulteriori chiarimenti sono qua.

    Grazie infinite!
    Jordy

    Le cose possono solo che migliorare!!!!

  2.  
  3. #2
    Senior Droid L'avatar di freebong


    Registrato dal
    Apr 2011
    Messaggi
    377

    Ringraziamenti
    13
    Ringraziato 28 volte in 27 Posts
    Predefinito

    Quote Originariamente inviato da Jordywild
    Ciao a tutti.
    Chiedo una piccola consulenza.
    Ho creato un'app con un form di login nativo (nel senso che ho creato una view con i dati di utenza e password da inserire).
    Oltre a questo ho inserito 2 bottoni:

    * il primo bottone serve per la login all'applicazione web (e fa partire una webview) gestita correttamente con Async
    * il secondo bottone serve per aprire un altro sito web statico (e parte sempre la webview con un altro url ma senza Async dato che non ci parametri da passare


    Il problema nasce dal fatto che se lancio l'applicazione su Gingerbread, non ho nessun problema con nessun bottone, ma da ICS in su, il 2 bottone instanzia correttamente la webview ma la pagina rimane bianca.
    Ho gi verificato che la pagina statica non contiene codice javascript per cui il problema non quello e il logcat non scrive assolutamente nulla in merito per cui non riesco a capire dove sbaglio.
    Ho cercato ovunque (anche su stackoverflow) ma non c' nessuno che ha avuto lo stesso problema.

    L'applicazione compilato con l'ultima versione dell'API (17): mi manca solo questo e poi potr pubblicare l'app su Play Store.

    Se avete bisogno di ulteriori chiarimenti sono qua.

    Grazie infinite!

    Ciao leggevo non molto tempo fa proprio su stackoverflow che a partire dalla 4.0 ci sono una serie bug noti sulle webview. Probabilmente per questo.


    Inviato dal mio HTC Desire usando Androidiani App

  4. #3
    Senior Droid


    Registrato dal
    Aug 2010
    Messaggi
    523
    Smartphone
    N6 - S4 Mini - N9 LTE

    Ringraziamenti
    29
    Ringraziato 19 volte in 18 Posts
    Predefinito

    Quote Originariamente inviato da freebong Visualizza il messaggio
    Ciao leggevo non molto tempo fa proprio su stackoverflow che a partire dalla 4.0 ci sono una serie bug noti sulle webview. Probabilmente per questo.


    Inviato dal mio HTC Desire usando Androidiani App
    L'ho letto anche io.
    Ma secondo me dovuto alla nuova versione di webkit che ha dei parametri pi stringenti in fatto di standard.
    Probabilmente il sito che voglio usare non compatibile (se volete vi d il link)
    Jordy

    Le cose possono solo che migliorare!!!!

  5. #4
    Senior Droid L'avatar di freebong


    Registrato dal
    Apr 2011
    Messaggi
    377

    Ringraziamenti
    13
    Ringraziato 28 volte in 27 Posts
    Predefinito

    Quote Originariamente inviato da Jordywild Visualizza il messaggio
    L'ho letto anche io.
    Ma secondo me dovuto alla nuova versione di webkit che ha dei parametri pi stringenti in fatto di standard.
    Probabilmente il sito che voglio usare non compatibile (se volete vi d il link)
    ok prova a postare il link

  6. #5
    Senior Droid


    Registrato dal
    Aug 2010
    Messaggi
    523
    Smartphone
    N6 - S4 Mini - N9 LTE

    Ringraziamenti
    29
    Ringraziato 19 volte in 18 Posts
    Predefinito

    Quote Originariamente inviato da freebong Visualizza il messaggio
    ok prova a postare il link
    Inviato via mp!
    Grazie!
    Jordy

    Le cose possono solo che migliorare!!!!

  7. #6
    Senior Droid L'avatar di freebong


    Registrato dal
    Apr 2011
    Messaggi
    377

    Ringraziamenti
    13
    Ringraziato 28 volte in 27 Posts
    Predefinito

    Ciao,
    allora a me funziona tutto su emulatore.. ho provato con Android 4.0 e l'applicazione compilata con le API versione 14 per, non 17 (la mia sdk non molto aggiornata ).
    Probabilmete il problema sta nella versione di API che usi..

  8. Il seguente Utente ha ringraziato freebong per il post:

    Jordywild (28-02-13)

  9. #7
    Senior Droid


    Registrato dal
    Aug 2010
    Messaggi
    523
    Smartphone
    N6 - S4 Mini - N9 LTE

    Ringraziamenti
    29
    Ringraziato 19 volte in 18 Posts
    Predefinito

    Quote Originariamente inviato da freebong Visualizza il messaggio
    Ciao,
    allora a me funziona tutto su emulatore.. ho provato con Android 4.0 e l'applicazione compilata con le API versione 14 per, non 17 (la mia sdk non molto aggiornata ).
    Probabilmete il problema sta nella versione di API che usi..
    Ok grazie!
    Provo a compilare con le API 16 e 15.

    Grazie
    Jordy

    Le cose possono solo che migliorare!!!!

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire risposte
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Privacy Policy