CERCA
PER MODELLO
FullScreen Chatbox! :)

Utente del giorno: Stahl con ben 18 Thanks ricevuti nelle ultime 24 ore
Utente della settimana: Stahl con ben 96 Thanks ricevuti negli ultimi sette giorni
Utente del mese: Stahl con ben 466 Thanks ricevuti nell'ultimo mese

Pagina 37 di 53 primaprima ... 27353637383947 ... ultimoultimo
Ultima pagina
Visualizzazione dei risultati da 361 a 370 su 526
Discussione:

[SCRIPT] Switch2SD (S2SD)- ovvero: Mai più problemi di memoria interna!

Se questa discussione ti è stata utile, ti preghiamo di lasciare un messaggio di feedback in modo che possa essere preziosa in futuro anche per altri utenti come te!
  1. #361
    Androidiano VIP L'avatar di Michelasso


    Registrato dal
    Apr 2012
    Località
    Treviso
    Messaggi
    3,215

    Ringraziamenti
    146
    Ringraziato 984 volte in 486 Posts
    Predefinito

    Quote Originariamente inviato da lamerhouse Visualizza il messaggio
    ciao michelasso

    scusa se ti rompo ...

    ma non riesco a capire leggendo tutti i post..

    io ho un gs3 un tablet p3110 il tab2 ... su entrambi cm 10.1 con il gs3 per ora non ho problemi.. ma con il tab 2 da 8 gb si ... ho dentro una sd da 32 gb vorrei installare il tuo script.. volevo sapere su 10.1 Cm funziona? e nel caso devo fare qualche procedura diversa?

    grazie in anticipo
    Il discorso è semplice. Servono 4 cose:

    1. Rooting con busybox
    2. Un custom Kernel che supporta /etc/init.d
    3. La SD card partizionata in 2 con la seconda partizione di 1GB (anche un po' più nel tuo caso) in formato ext2/ext3/ext4
    4. Installare S2SD

    per 1. - 3. devi chiedere nella sezione del tuo dispositivo. Con CM 10.1 dovresti avere già 1. e 2. Quando hai fatto tutto installa S2SD e fai reboot. Controlla il file

    /data/log/S2SD_log.txt

    e vedi se tutto è andato a buon fine (si capisce, il log è molto dettagliato). Se invece non parte S2SD come dovrebbe posta il log qui.

    Quote Originariamente inviato da Adrix64 Visualizza il messaggio
    Un grazie a Samurri e Michelasso, come suggerito, riposto la domanda nella sezione del mio telefono.

    Grazie e ancora Buon Anno a tutti
    Bene. Magari facci sapere qual'era il problema, giusto per curiosità. E buon anno pure a te!
    Se sono stato utile non dimenticare di premere Thanks!

    Visita la mia collezione di temi per telefoni e tablet Xperia!


  2.  
  3. #362
    Baby Droid


    Registrato dal
    Dec 2012
    Messaggi
    21

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Quote Originariamente inviato da Michelasso Visualizza il messaggio
    Il discorso è semplice. Servono 4 cose:

    1. Rooting con busybox
    2. Un custom Kernel che supporta /etc/init.d
    3. La SD card partizionata in 2 con la seconda partizione di 1GB (anche un po' più nel tuo caso) in formato ext2/ext3/ext4
    4. Installare S2SD

    per 1. - 3. devi chiedere nella sezione del tuo dispositivo. Con CM 10.1 dovresti avere già 1. e 2. Quando hai fatto tutto installa S2SD e fai reboot. Controlla il file

    /data/log/S2SD_log.txt

    e vedi se tutto è andato a buon fine (si capisce, il log è molto dettagliato). Se invece non parte S2SD come dovrebbe posta il log qui.



    Bene. Magari facci sapere qual'era il problema, giusto per curiosità. E buon anno pure a te!
    Ciao Michelasso, no, ho sicuramente sbagliato il modo di scrivere, l'ho detto che sono poco pratico di forum

    era solo perchè in precedenza mi hai consigliato di postare nella sezione del mio cellulare, e così ho fatto, ma

    volevo ringraziare e fare gli auguri a chi come te comunque aveva cercato di rispondere e a tutti quelli

    che usano il forum.

    Rinnovati auguri

  4. #363
    Baby Droid


    Registrato dal
    Aug 2012
    Messaggi
    18

    Ringraziamenti
    1
    Ringraziato 0 volte in 0 Posts
    Predefinito

    grazie per la risposta ora sto provando ... ho riformattato tutto perché inizialmente dava solo errori di programmi a gogo .. ed aveva riempito in 2 secondi la partizione da 1 gb ext e la fat 32 neanche la considerava... cmq. ora sto riprovando...
    ma nuova domanda .. se domani come al solito esce aggiornamento della CM io di solito cancello la wipe e la dalvik e con CWM installo la nuova .. facendo cosi ..cancello il tuo script?

    grazie ancora

  5. #364
    Androidiano VIP L'avatar di Michelasso


    Registrato dal
    Apr 2012
    Località
    Treviso
    Messaggi
    3,215

    Ringraziamenti
    146
    Ringraziato 984 volte in 486 Posts
    Predefinito

    Quote Originariamente inviato da lamerhouse Visualizza il messaggio
    grazie per la risposta ora sto provando ... ho riformattato tutto perché inizialmente dava solo errori di programmi a gogo .. ed aveva riempito in 2 secondi la partizione da 1 gb ext e la fat 32 neanche la considerava... cmq. ora sto riprovando...
    ma nuova domanda .. se domani come al solito esce aggiornamento della CM io di solito cancello la wipe e la dalvik e con CWM installo la nuova .. facendo cosi ..cancello il tuo script?

    grazie ancora
    Cancellando dati e dalvik non succede nulla. L'unica cosa è se installi una nuova rom, che cancella /system. Basta che ti ricordi di rimetterlo. tanto te ne accorgi subito se non è installato, ti spariscono tutte le applicazioni che hai scaricato… Ma non appena rimetti lo script le ritrova.
    Se sono stato utile non dimenticare di premere Thanks!

    Visita la mia collezione di temi per telefoni e tablet Xperia!


  6. #365
    Baby Droid


    Registrato dal
    Aug 2012
    Messaggi
    18

    Ringraziamenti
    1
    Ringraziato 0 volte in 0 Posts
    Predefinito

    Quote Originariamente inviato da Michelasso Visualizza il messaggio
    Cancellando dati e dalvik non succede nulla. L'unica cosa è se installi una nuova rom, che cancella /system. Basta che ti ricordi di rimetterlo. tanto te ne accorgi subito se non è installato, ti spariscono tutte le applicazioni che hai scaricato… Ma non appena rimetti lo script le ritrova.
    ciao

    allora.. molti problemi... ho cercato di capire .. ma sonoin alto mare .. ti riassumo....
    dopo aver riformattato tutto reinstallato tutto nuovo sempre cm 10.1 su 3110 tab 2 galaxy ... ho installato il tuo script ..nessun errore..
    ho iniziato ad installare le app e sembrava che la memoria interna non venisse caricata ma le app funzionavano... ma il tuo log non esisteva nella cartella ..neanche l'ombra del file vuoto.. va bè continuo.. sembra tutto ok.... il giorno dopo vado per aprire un app. e mi dice anche se le icone di tutte le app sono presenti .. "applicazione non installata" questo di tutte le app tranne quelle di Google... ok .. apro Freespace ..e mi dice sempre che la partizione SD-CARD e vuota .. ma non vuota con gb proprio senza dati come se non esistesse.... la microsd era tutto ok.. allora provo a disinstallare il tuo script reinstallo le app mancanti e tutto torna ok.. installo per prova link2sd ... mi rileva la Microsd con doppia partizione gli dico ext 4 ... mi dice riavvia .. rientro in link e mi continua a dire con rilega la seconda partizione ma non riesce a montarla... guardo dentro memoria con link2sd e li mi dice

    interna 85% libera 3.92 GB /data
    Scheda SD 85% libera 3.92 GB /storage/emulated/0
    Ext. sd 97% libera con 27 GB /storage/sdcard1
    2 partizione scheda SD 84% libera 1.70 GB /data/sdext2
    sistema 73% libera 0.99 GB /system
    cache 88% libera con 609 MB /cache

    ora che con link2cd se tento di spostare un applicazione in scheda SD mi dice che non c'è spazio.. OK non riesce a montare la seconda partizione .. ma sai dirmi il perché???? ... forse bisogna sistema i path che su 4.2.1 sono diversi???? che li vede dentro la cartella emulated?????

    ti servono altri dati ..??? purtroppo nessun log del tuo script era presente

    grazie ancora

  7. #366
    Androidiano VIP L'avatar di Michelasso


    Registrato dal
    Apr 2012
    Località
    Treviso
    Messaggi
    3,215

    Ringraziamenti
    146
    Ringraziato 984 volte in 486 Posts
    Predefinito

    E allora non capisco che problema ci sia con il kernel della CM10. Se il file di log di S2SD proprio non esiste vuol dire che lo script non viene lanciato. Non sei il primo che dice che questo è il caso con CM10. Funziona però con la CM10 del Galaxy Next (non Turbo. Il Turbo non ha alcuna CM funzionante).

    Comunque che anche Link2SD dia problemi non è bello. Una cosa che puoi provare a fare è lanciare lo script

    /etc/init.d/02Switch2SD

    come root da Root Browser (lite per la versione free). Poi vedere che c'è dentro al log (lo script comunque non terminerà l'esecuzione come deve essendo che Android con tutte le sue app ormai è attivo). Se esiste un log.
    Se sono stato utile non dimenticare di premere Thanks!

    Visita la mia collezione di temi per telefoni e tablet Xperia!


  8. #367
    Baby Droid


    Registrato dal
    Aug 2012
    Messaggi
    18

    Ringraziamenti
    1
    Ringraziato 0 volte in 0 Posts
    Predefinito

    Quote Originariamente inviato da Michelasso Visualizza il messaggio
    E allora non capisco che problema ci sia con il kernel della CM10. Se il file di log di S2SD proprio non esiste vuol dire che lo script non viene lanciato. Non sei il primo che dice che questo è il caso con CM10. Funziona però con la CM10 del Galaxy Next (non Turbo. Il Turbo non ha alcuna CM funzionante).

    Comunque che anche Link2SD dia problemi non è bello. Una cosa che puoi provare a fare è lanciare lo script

    /etc/init.d/02Switch2SD

    come root da Root Browser (lite per la versione free). Poi vedere che c'è dentro al log (lo script comunque non terminerà l'esecuzione come deve essendo che Android con tutte le sue app ormai è attivo). Se esiste un log.
    grazie ancora per il tempo che stai perdendo ... e buon anno
    lo script di link2sd esiste e lo riscrivo qui sotto

    #!/system/bin/sh
    #added by link2sd
    LOG=/data/link2sd-11link2sd.log
    echo "$(date) mounting..." > $LOG
    mount -t ext4 -o rw /dev/block/vold/179:26 /data/sdext2 1>>$LOG 2>>$LOG

    mount -t ext4 -o rw /dev/block/mmcblk1p2 /data/sdext2 1>>$LOG 2>>$LOG

    mount >> $LOG
    echo "$(date) mount finished" >> $LOG

    questo e il log generato
    Mon Dec 31 13:45:57 CET 2012 mounting...
    mount: Device or resource busy
    mount: Device or resource busy
    rootfs / rootfs ro,relatime 0 0
    tmpfs /dev tmpfs rw,nosuid,relatime,mode=755 0 0
    devpts /dev/pts devpts rw,relatime,mode=600 0 0
    none /dev/cpuctl cgroup rw,relatime,cpu 0 0
    proc /proc proc rw,relatime 0 0
    sysfs /sys sysfs rw,relatime 0 0
    /sys/kernel/debug /sys/kernel/debug debugfs rw,relatime 0 0
    none /acct cgroup rw,relatime,cpuacct 0 0
    tmpfs /mnt/secure tmpfs rw,relatime,mode=700 0 0
    tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
    /dev/block/dm-0 /mnt/asec/com.clickntap.applix.mondadori.edicola-1 ext4 ro,dirsync,nosuid,nodev,noatime,barrier=1 0 0
    tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
    /dev/block/platform/omap/omap_hsmmc.1/by-name/FACTORYFS /system ext4 ro,relatime,barrier=1,data=ordered 0 0
    /dev/block/platform/omap/omap_hsmmc.1/by-name/EFS /efs ext4 rw,nosuid,nodev,relatime,barrier=1,data=ordered 0 0
    /dev/block/platform/omap/omap_hsmmc.1/by-name/DATAFS /data ext4 rw,nosuid,nodev,noatime,barrier=1,journal_async_co mmit,data=ordered,noauto_da_alloc,discard 0 0
    /dev/block/vold/179:26 /data/sdext2 ext4 rw,relatime,barrier=1,data=ordered 0 0
    /dev/block/platform/omap/omap_hsmmc.1/by-name/CACHE /cache ext4 rw,nosuid,nodev,noatime,barrier=1,journal_async_co mmit,data=ordered,noauto_da_alloc,discard 0 0
    /dev/fuse /mnt/shell/emulated fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=102 3,default_permissions,allow_other 0 0
    tmpfs /storage/emulated tmpfs rw,nosuid,nodev,relatime,mode=050,gid=1028 0 0
    /dev/block/vold/179:25 /storage/sdcard1 vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,g id=1015,fmask=0702,dmask=0702,allow_utime=0020,cod epage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
    /dev/fuse /storage/emulated/0 fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=102 3,default_permissions,allow_other 0 0
    /dev/fuse /storage/emulated/0/Android/obb fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=102 3,default_permissions,allow_other 0 0
    /dev/fuse /storage/emulated/legacy fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=102 3,default_permissions,allow_other 0 0
    /dev/fuse /storage/emulated/legacy/Android/obb fuse rw,nosuid,nodev,relatime,user_id=1023,group_id=102 3,default_permissions,allow_other 0 0
    Mon Dec 31 13:45:57 CET 2012 mount finished
    Ultima modifica di lamerhouse; 31-12-12 alle 14:48

  9. #368
    Androidiano VIP L'avatar di Michelasso


    Registrato dal
    Apr 2012
    Località
    Treviso
    Messaggi
    3,215

    Ringraziamenti
    146
    Ringraziato 984 volte in 486 Posts
    Predefinito

    In realtà avevo detto di lanciare lo script

    /etc/init.d/02Switch2SD

    quello di S2SD, non di Link2SD. E poi controllare il log di S2SD:

    /data/log/S2SD_log.txt
    Se sono stato utile non dimenticare di premere Thanks!

    Visita la mia collezione di temi per telefoni e tablet Xperia!


  10. #369
    Baby Droid


    Registrato dal
    Aug 2012
    Messaggi
    18

    Ringraziamenti
    1
    Ringraziato 0 volte in 0 Posts
    Predefinito

    Quote Originariamente inviato da Michelasso Visualizza il messaggio
    In realtà avevo detto di lanciare lo script

    /etc/init.d/02Switch2SD

    quello di S2SD, non di Link2SD. E poi controllare il log di S2SD:

    /data/log/S2SD_log.txt
    sorry...

    il tuo log dice:
    questo nel popup appena lanci lo script
    exit value: 1

    stdout:
    null

    stderr:
    touch: /etc/mtab: read-only file system
    --install: applet not found
    grep: /res/recovery.fstab: no such file or directory




    -----------
    questo il file di log che ho trovato
    2012-12-29 18:32:23: Switch2SD started
    2012-12-29 18:32:23: SD FAT partition is
    2012-12-29 18:32:23: Directory /sd-ext created
    2012-12-29 18:32:23: Loop 1: Waiting for SD card to be ready
    2012-12-29 18:32:24: Loop 2: Waiting for SD card to be ready
    2012-12-29 18:32:26: Loop 3: Waiting for SD card to be ready
    2012-12-29 18:32:27: Loop 4: Waiting for SD card to be ready
    2012-12-29 18:32:28: Loop 5: Waiting for SD card to be ready
    2012-12-29 18:32:29: Loop 6: Waiting for SD card to be ready
    2012-12-29 18:32:30: Loop 7: Waiting for SD card to be ready
    2012-12-29 18:32:31: Loop 8: Waiting for SD card to be ready
    2012-12-29 18:32:32: Loop 9: Waiting for SD card to be ready
    2012-12-29 18:32:33: SD card not recognized yet. Assuming partition is /dev/block/mmcblk0p2
    2012-12-29 18:32:33: No huge_file property detected on /dev/block/mmcblk0p2
    2012-12-29 18:32:33: Running e2fsck on /dev/block/mmcblk0p2
    2012-12-29 18:32:34: Unable to repair filesystem /dev/block/mmcblk0p2
    2012-12-29 18:32:34: You need to repair the second partition from Linux or reformat the partion
    2012-12-29 18:32:34: e2fsck: Bad magic number in super-block while trying to open /dev/block/mmcblk0p2
    /dev/block/mmcblk0p2:
    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
    #
    2012-12-29 19:40:32: Switch2SD started
    2012-12-29 19:40:32: SD FAT partition is
    2012-12-29 19:40:32: Directory /sd-ext created
    2012-12-29 19:40:32: SD ext partition is /dev/block/mmcblk1p2
    2012-12-29 19:40:32: No huge_file property detected on /dev/block/mmcblk1p2
    2012-12-29 19:40:33: Running e2fsck on /dev/block/mmcblk1p2
    2012-12-29 19:41:33: Partition /dev/block/mmcblk1p2 checked. Mounting /sd-ext
    2012-12-29 19:41:33: Directory /sd-ext successfully mounted on /dev/block/mmcblk1p2
    2012-12-29 19:41:34: Moving /data/app/com.pacosal.acc-1.apk to /sd-ext
    2012-12-29 19:41:34: Switch2SD ended successfully
    #
    2012-12-29 19:46:52: Switch2SD started
    2012-12-29 19:46:52: SD FAT partition is
    2012-12-29 19:46:52: Directory /sd-ext created
    2012-12-29 19:46:52: SD ext partition is /dev/block/mmcblk1p2
    2012-12-29 19:46:52: No huge_file property detected on /dev/block/mmcblk1p2
    2012-12-29 19:46:53: Running e2fsck on /dev/block/mmcblk1p2
    2012-12-29 19:47:51: Partition /dev/block/mmcblk1p2 checked. Mounting /sd-ext
    2012-12-29 19:47:51: Directory /sd-ext successfully mounted on /dev/block/mmcblk1p2
    2012-12-29 19:47:51: No apps to move to /sd-ext
    2012-12-29 19:47:51: Switch2SD ended successfully
    #
    2012-12-30 12:59:59: Switch2SD started
    2012-12-30 12:59:59: SD FAT partition is
    2012-12-30 12:59:59: Directory /sd-ext created
    2012-12-30 13:00:00: SD ext partition is /dev/block/mmcblk1p2
    2012-12-30 13:00:00: No huge_file property detected on /dev/block/mmcblk1p2
    2012-12-30 13:00:00: Running e2fsck on /dev/block/mmcblk1p2
    2012-12-30 13:01:01: Partition /dev/block/mmcblk1p2 checked. Mounting /sd-ext
    2012-12-30 13:01:01: Directory /sd-ext successfully mounted on /dev/block/mmcblk1p2
    2012-12-30 13:01:01: No apps to move to /sd-ext
    2012-12-30 13:01:01: Switch2SD ended successfully
    #
    2013-01-01 16:04:17: Switch2SD started
    2013-01-01 16:04:18: SD FAT partition is
    2013-01-01 16:04:18: Directory /sd-ext created
    2013-01-01 16:04:18: SD ext partition is /dev/block/mmcblk1p2
    2013-01-01 16:04:18: No huge_file property detected on /dev/block/mmcblk1p2
    2013-01-01 16:04:19: Running e2fsck on /dev/block/mmcblk1p2
    2013-01-01 16:04:19: Unable to repair filesystem /dev/block/mmcblk1p2
    2013-01-01 16:04:19: You need to repair the second partition from Linux or reformat the partion
    2013-01-01 16:04:19: e2fsck: Device or resource busy while trying to open /dev/block/mmcblk1p2
    Filesystem mounted or opened exclusively by another program?
    #
    2013-01-01 16:08:37: Switch2SD started
    2013-01-01 16:08:37: SD FAT partition is
    2013-01-01 16:08:37: Directory /sd-ext created
    xt partition is /dev/block/mmcblk1p2
    2013-01-01 16:08:37: No huge_file property detected on /dev/block/mmcblk1p2
    2013-01-01 16:08:38: Running e2fsck on /dev/block/mmcblk1p2
    2013-01-01 16:08:38: Unable to repair filesystem /dev/block/mmcblk1p2
    2013-01-01 16:08:38: You need to repair the second partition from Linux or reformat the partion
    2013-01-01 16:08:38: e2fsck: Device or resource busy while trying to open /dev/block/mmcblk1p2
    Filesystem mounted or opened exclusively by another program?
    #
    2013-01-01 16:11:20: Switch2SD started
    2013-01-01 16:11:20: SD FAT partition is
    2013-01-01 16:11:21: Directory /sd-ext created
    2013-01-01 16:11:21: SD ext partition is /dev/block/mmcblk1p2
    2013-01-01 16:11:21: Switch2SD /dev/block/mmcblk1p2 is already mounted. Exiting
    #
    2013-01-01 16:15:48: Switch2SD started
    2013-01-01 16:15:48: SD FAT partition is
    2013-01-01 16:15:48: Directory /sd-ext created
    2013-01-01 16:15:48: SD ext partition is /dev/block/mmcblk1p2
    2013-01-01 16:15:48: Switch2SD /dev/block/mmcblk1p2 is already mounted. Exiting
    #
    2013-01-01 16:18:29: Switch2SD started
    2013-01-01 16:18:29: SD FAT partition is
    2013-01-01 16:18:29: Directory /sd-ext created
    2013-01-01 16:18:29: SD ext partition is /dev/block/mmcblk1p2
    2013-01-01 16:18:29: Switch2SD /dev/block/mmcblk1p2 is already mounted. Exiting
    Ultima modifica di lamerhouse; 01-01-13 alle 17:22

  11. #370
    Androidiano VIP L'avatar di Michelasso


    Registrato dal
    Apr 2012
    Località
    Treviso
    Messaggi
    3,215

    Ringraziamenti
    146
    Ringraziato 984 volte in 486 Posts
    Predefinito

    Dal log sembra a posto. Nel senso che S2SD dopo il boot fa quello che deve. Cioè, è fallita solo la prima volta, non trovva la SD card. Sicuro che non stia funzionando? Freespace la vede ls partizione Ext? Tieni conto che tu avevi solo una applicazione nella memoria interna:

    com.pacosal.acc-1k.apk

    Che non so cosa sia. L'unica cosa che non capisco è perché lo script di Link2SD sia ancora li. Non è che hai messo Link2SD nella SD card?? Se si, disinstallalo assolutamente. Poi fai reboot.
    Se sono stato utile non dimenticare di premere Thanks!

    Visita la mia collezione di temi per telefoni e tablet Xperia!


Pagina 37 di 53 primaprima ... 27353637383947 ... ultimoultimo
Ultima pagina

Tag per questa discussione

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire risposte
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Torna su
Privacy Policy