CERCA
PER MODELLO
FullScreen Chatbox! :)

Utente del giorno: gianpassa con ben 5 Thanks ricevuti nelle ultime 24 ore
Utente della settimana: gianpassa con ben 30 Thanks ricevuti negli ultimi sette giorni
Utente del mese: gianpassa con ben 106 Thanks ricevuti nell'ultimo mese

Visualizzazione dei risultati da 1 a 9 su 9
Discussione:

Nuovo di Android

Se questa discussione ti è stata utile, ti preghiamo di lasciare un messaggio di feedback in modo che possa essere preziosa in futuro anche per altri utenti come te!
  1. #1
    Baby Droid L'avatar di ivanomonti


    Registrato dal
    Apr 2009
    Località
    Milano dintorni
    Messaggi
    29

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Nuovo di Android

    Salve a tutti e buona domenica ... Sono nuovo di questo forum e mi sto affascinando di Android che forse mi prendo al posto di iPhone :-).

    Vengo dal mondo Mac e quindi guardo molto la parte funzionale di un sistema e vorrei creare la mia prima applicazione per Android.

    Ho scaricato SDK di Android Mac X86 1.1 r1, dove dentro ho trovato Android.jar e relative cartelle e file ma mi da errori al suo lancio.

    iMac 2.4 Intel
    System 10.5.6
    Memoria 4 Gb

    Il messaggio di errore é:

    IMPOSSIBILE LANCIARE IL DOCUMENTO JAR JAVA "ANDROID.JAR"

    qui mi perdo ... qualcuno può darmi delle indicazioni, nel frattempo mi registro RSS sperando di risolvere quanto prima.

    Mi trovate anche sotto skype, iChat come "ivanomonti"

    Cordiali saluti Ivano Monti

  2.  
  3. #2
    Androidiano VIP L'avatar di nk02


    Registrato dal
    Mar 2009
    Messaggi
    4,016

    Ringraziamenti
    10
    Ringraziato 506 volte in 260 Posts
    Predefinito

    non devi avviare android.jar
    installa Eclipse (ottimo ambiente di sviluppo java, multipiattaforma), fai Help>SoftwareUpdate>AvaibleSoftware e clicca ADD SITE. Inserisci http://dl-ssl.google.com/android/eclipse/ (se ti da errore sull'https tranquillo, è normale), poi sulla sinistra apri il sottomenu di "http://dl-ssl.google.com/android/eclipse/", e installa i "Developer Tools".
    A quel punto vai su Window>Preferences>Android e scegli il percorso in cui hai salvato l'sdk.

    ora puoi creare un nuovo "Android project" e scrivere tutto il codice che vuoi : )

    ps: nell'sdk, nella directory "tools", c'è l'emulatore per provare android ^^ lo stesso che userà eclipse per runnare le tue applicazione direttamente in ambiente android

  4. #3
    Baby Droid L'avatar di ivanomonti


    Registrato dal
    Apr 2009
    Località
    Milano dintorni
    Messaggi
    29

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Quote Originariamente inviato da nk02 Visualizza il messaggio
    non devi avviare android.jar
    installa Eclipse (ottimo ambiente di sviluppo java, multipiattaforma), fai Help>SoftwareUpdate>AvaibleSoftware e clicca ADD SITE. Inserisci http://dl-ssl.google.com/android/eclipse/ (se ti da errore sull'https tranquillo, è normale), poi sulla sinistra apri il sottomenu di "http://dl-ssl.google.com/android/eclipse/", e installa i "Developer Tools".
    A quel punto vai su Window>Preferences>Android e scegli il percorso in cui hai salvato l'sdk.

    ora puoi creare un nuovo "Android project" e scrivere tutto il codice che vuoi : )

    ps: nell'sdk, nella directory "tools", c'è l'emulatore per provare android ^^ lo stesso che userà eclipse per runnare le tue applicazione direttamente in ambiente android
    Provo a fare quando dici poi ti aggiorno ... grazie infinite.
    Ivano Monti
    Developer for Mac and Windows
    Url: http://www.ivanomonti.eu
    Google Map 45.62224,9.107407

  5. #4
    Androidiano VIP L'avatar di nk02


    Registrato dal
    Mar 2009
    Messaggi
    4,016

    Ringraziamenti
    10
    Ringraziato 506 volte in 260 Posts
    Predefinito

    Quote Originariamente inviato da ivanomonti Visualizza il messaggio
    Provo a fare quando dici poi ti aggiorno ... grazie infinite.
    di niente

  6. #5
    Baby Droid L'avatar di ivanomonti


    Registrato dal
    Apr 2009
    Località
    Milano dintorni
    Messaggi
    29

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Quote Originariamente inviato da nk02 Visualizza il messaggio
    di niente
    Non mi fa eseguire un project di Android... mi indica un errore di tipo " Package name must have at least two identifiers."

    ... come posso inviare uno screen ?

    Ivano Monti
    Developer for Mac and Windows
    Url: http://www.ivanomonti.eu
    Google Map 45.62224,9.107407

  7. #6
    Administrator L'avatar di Andrea


    Registrato dal
    Nov 2008
    Messaggi
    3,370
    Smartphone
    Nexus S, myTouch Slide 4g

    Ringraziamenti
    143
    Ringraziato 877 volte in 322 Posts
    Predefinito

    il package name deve essere almeno uno.due

    Per quello ti dice cosi :P

    Twitter @veke87

  8. #7
    Androidiano VIP


    Registrato dal
    Mar 2009
    Messaggi
    105

    Ringraziamenti
    0
    Ringraziato 1 volta in 1 Post
    Predefinito

    Segui la documentazione seguente ti guiderà passo passo a sviluppare la tua prima applicazione: qui.O altrimenti quella in italiano fatta da Gonçalo Margalho qui

  9. #8
    Baby Droid


    Registrato dal
    Apr 2009
    Messaggi
    4

    Ringraziamenti
    0
    Ringraziato 0 volte in 0 Posts
    Predefinito

    Salve, anchio sono nuovo, ho studiato java a scuola, ma ho usato solo un programma che si chiama realj e ho provato un po (poco) x conto mio netbeans

    ora sto scaricando eclipse.
    volevo chiedere:
    io sto scaricando la versione "Eclipse Classic 3.4.2" è quella corretta?

    edit:
    ok, ritiro la domanda
    installato eclipse, installato il componente aggiuntivo (da locale, nella procedura spiegata sopra mi dava errore)
    fatto il programmino "hello" illustrato nella documentazione di Gonçalo Margalho

    e funge tutto
    bene, son pronto a partire
    Ultima modifica di Mirko88; 23-04-09 alle 22:10

  10. #9
    Androidiano VIP L'avatar di Gg636


    Registrato dal
    Aug 2012
    Località
    Salerno
    Messaggi
    1,146
    Smartphone
    Galaxy Giò e S II ; Nexus 7

    Ringraziamenti
    2,097
    Ringraziato 1,174 volte in 670 Posts
    Predefinito

    Quote Originariamente inviato da ivanomonti Visualizza il messaggio
    Non mi fa eseguire un project di Android... mi indica un errore di tipo " Package name must have at least two identifiers."

    ... come posso inviare uno screen ?

    Aee... lì ti voglio...

    Gg
    GRUPPO S. P. A. M. © all rights reserved ®
    Sempre Pronti A Metterlo

Discussioni simili

  1. Nuovo iGo per Android
    Da MarkFI nel forum Le Applicazioni per Android
    Risposte: 6
    Ultimo messaggio: 19-01-13, 10:45
  2. nuovo cellulare android
    Da pol18 nel forum Android Cafè
    Risposte: 2
    Ultimo messaggio: 10-01-10, 18:46
  3. Nuovo Android Economico
    Da TheSgrash nel forum Android Cafè
    Risposte: 3
    Ultimo messaggio: 19-12-09, 20:58
  4. nuovo terminale android....
    Da andreacerioni nel forum Android Cafè
    Risposte: 0
    Ultimo messaggio: 26-11-09, 15:56
  5. Nuovo Android per me
    Da TheSgrash nel forum Android Cafè
    Risposte: 15
    Ultimo messaggio: 06-11-09, 09:30

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire risposte
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Torna su
Privacy Policy