CERCA
PER MODELLO
FullScreen Chatbox! :)

Utente del giorno: carotix con ben 4 Thanks ricevuti nelle ultime 24 ore
Utente della settimana: gianpassa con ben 18 Thanks ricevuti negli ultimi sette giorni
Utente del mese: 9mm con ben 135 Thanks ricevuti nell'ultimo mese

Visualizzazione dei risultati da 1 a 6 su 6
Discussione:

Configurare Azilink

Se questa discussione ti è stata utile, ti preghiamo di lasciare un messaggio di feedback in modo che possa essere preziosa in futuro anche per altri utenti come te!
  1. #1
    Baby Droid


    Registrato dal
    Sep 2009
    Messaggi
    5

    Ringraziamenti
    0
    Ringraziato 0 volte in 0 Posts
    Predefinito

    Configurare Azilink

    Salve a tutti,

    seguendo la guida presente nel forum ho installato Azilink per effettuare il tethering USB con il mio Magic, ma non mi funziona.

    Il mio file di configurazione azilink.avpn contiene:

    dev tun

    remote 127.0.0.1 41927 tcp-client

    ifconfig 192.168.56.2 192.168.56.1

    route 0.0.0.0 128.0.0.0
    route 128.0.0.0 128.0.0.0

    #socket-flags TCP_NODELAY
    #keepalive 10 30

    ping 10
    dhcp-option DNS 192.168.56.1

    route-method exe
    route-delay 2
    ed il risultato dello status di OpenVPN è:

    Mon Sep 14 22:55:17 2009 us=709000 Current Parameter Settings:
    Mon Sep 14 22:55:17 2009 us=709000 config = 'azilink.ovpn'
    Mon Sep 14 22:55:17 2009 us=709000 mode = 0
    Mon Sep 14 22:55:17 2009 us=709000 show_ciphers = DISABLED
    Mon Sep 14 22:55:17 2009 us=709000 show_digests = DISABLED
    Mon Sep 14 22:55:17 2009 us=709000 show_engines = DISABLED
    Mon Sep 14 22:55:17 2009 us=709000 genkey = DISABLED
    Mon Sep 14 22:55:17 2009 us=709000 key_pass_file = '[UNDEF]'
    Mon Sep 14 22:55:17 2009 us=709000 show_tls_ciphers = DISABLED
    Mon Sep 14 22:55:17 2009 us=709000 Connection profiles [default]:
    Mon Sep 14 22:55:17 2009 us=709000 NOTE: --mute triggered...
    Mon Sep 14 22:55:17 2009 us=709000 262 variation(s) on previous 10 message(s) suppressed by --mute
    Mon Sep 14 22:55:17 2009 us=709000 OpenVPN 2.1_rc19 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Jul 16 2009
    Mon Sep 14 22:55:17 2009 us=709000 WARNING: --ping should normally be used with --ping-restart or --ping-exit
    Mon Sep 14 22:55:17 2009 us=709000 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
    Mon Sep 14 22:55:17 2009 us=709000 ******* WARNING *******: all encryption and authentication features disabled -- all data will be tunnelled as cleartext
    Mon Sep 14 22:55:17 2009 us=725000 ROUTE: default_gateway=UNDEF
    Mon Sep 14 22:55:17 2009 us=740000 TAP-WIN32 device [Connessione alla rete locale (LAN) 2] opened: \\.\Global\{6E92E202-8337-457C-8200-FC105EDAA27A}.tap
    Mon Sep 14 22:55:17 2009 us=740000 TAP-Win32 Driver Version 9.6
    Mon Sep 14 22:55:17 2009 us=740000 TAP-Win32 MTU=1500
    Mon Sep 14 22:55:17 2009 us=740000 Notified TAP-Win32 driver to set a DHCP IP/netmask of 192.168.56.2/255.255.255.252 on interface {6E92E202-8337-457C-8200-FC105EDAA27A} [DHCP-serv: 192.168.56.1, lease-time: 31536000]
    Mon Sep 14 22:55:17 2009 us=740000 DHCP option string: 0604c0a8 3801
    Mon Sep 14 22:55:17 2009 us=740000 Successful ARP Flush on interface [18] {6E92E202-8337-457C-8200-FC105EDAA27A}
    Mon Sep 14 22:55:17 2009 us=756000 Data Channel MTU parms [ L:1502 D:1450 EF:2 EB:4 ET:0 EL:0 AF:14/2 ]
    Mon Sep 14 22:55:17 2009 us=756000 Local Options String: 'V4,dev-type tun,link-mtu 1502,tun-mtu 1500,proto TCPv4_CLIENT,ifconfig 192.168.56.1 192.168.56.2'
    Mon Sep 14 22:55:17 2009 us=756000 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1502,tun-mtu 1500,proto TCPv4_SERVER,ifconfig 192.168.56.2 192.168.56.1'
    Mon Sep 14 22:55:17 2009 us=756000 Local Options hash (VER=V4): '14d5141a'
    Mon Sep 14 22:55:17 2009 us=756000 Expected Remote Options hash (VER=V4): '84280bec'
    Mon Sep 14 22:55:17 2009 us=756000 Attempting to establish TCP connection with 127.0.0.1:41927
    Mon Sep 14 22:55:17 2009 us=756000 TCP connection established with 127.0.0.1:41927
    Mon Sep 14 22:55:17 2009 us=756000 Socket Buffers: R=[8192->8192] S=[8192->8192]
    Mon Sep 14 22:55:17 2009 us=756000 TCPv4_CLIENT link local: [undef]
    Mon Sep 14 22:55:17 2009 us=756000 TCPv4_CLIENT link remote: 127.0.0.1:41927
    Mon Sep 14 22:55:27 2009 us=7000 Peer Connection Initiated with 127.0.0.1:41927
    Mon Sep 14 22:55:33 2009 us=403000 TEST ROUTES: 1/1 succeeded len=1 ret=1 a=0 u/d=up
    Mon Sep 14 22:55:33 2009 us=403000 C:\WINDOWS\system32\route.exe ADD 192.168.56.0 MASK 255.255.255.252 192.168.56.1
    Mon Sep 14 22:55:33 2009 us=481000 Initialization Sequence Completed
    Qualcuno mi può aiutare?
    Grazie mille.

  2.  
  3. #2
    Androidiano VIP L'avatar di elegos


    Registrato dal
    Jul 2009
    Messaggi
    1,714

    Ringraziamenti
    2
    Ringraziato 153 volte in 120 Posts
    Predefinito

    Che errore ti dà? Non riesci a navigare su internet?
    Hai provato a fare un ping?
    ping Google
    ping 209.85.129.103

  4. #3
    Baby Droid


    Registrato dal
    Sep 2009
    Messaggi
    5

    Ringraziamenti
    0
    Ringraziato 0 volte in 0 Posts
    Predefinito

    La cosa strana è che non mi da errori, il logo con i due computerini di OpenVPN diventa verde e il programma nel Magic mi scrive "Connected to host".

    Ho provato a fare il ping 192.168.56.1 e non da alcun errore.

    Ho provato a modificare il file di configurazione lasciando praticamente invariati i parametri impostati come segue:


    dev tun

    remote 127.0.0.1 41927 tcp-client
    ifconfig 192.168.56.2 192.168.56.1
    route 0.0.0.0 128.0.0.0
    route 128.0.0.0 128.0.0.0
    #socket-flags TCP_NODELAY
    #keepalive 10 30
    ping 10
    dhcp-option DNS 192.168.56.1

    route-method exe
    route-delay 2
    ed lo status una volta effettuata la connessione è:


    Thu Sep 17 12:10:14 2009 OpenVPN 2.1_rc19 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Jul 16 2009
    Thu Sep 17 12:10:14 2009 WARNING: --ping should normally be used with --ping-restart or --ping-exit
    Thu Sep 17 12:10:14 2009 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
    Thu Sep 17 12:10:14 2009 ******* WARNING *******: all encryption and authentication features disabled -- all data will be tunnelled as cleartext
    Thu Sep 17 12:10:14 2009 TAP-WIN32 device [Connessione alla rete locale (LAN) 2] opened: \\.\Global\{6E92E202-8337-457C-8200-FC105EDAA27A}.tap
    Thu Sep 17 12:10:14 2009 Notified TAP-Win32 driver to set a DHCP IP/netmask of 192.168.56.2/255.255.255.252 on interface {6E92E202-8337-457C-8200-FC105EDAA27A} [DHCP-serv: 192.168.56.1, lease-time: 31536000]
    Thu Sep 17 12:10:14 2009 Successful ARP Flush on interface [18] {6E92E202-8337-457C-8200-FC105EDAA27A}
    Thu Sep 17 12:10:14 2009 Attempting to establish TCP connection with 127.0.0.1:41927
    Thu Sep 17 12:10:14 2009 TCP connection established with 127.0.0.1:41927
    Thu Sep 17 12:10:14 2009 TCPv4_CLIENT link local: [undef]
    Thu Sep 17 12:10:14 2009 TCPv4_CLIENT link remote: 127.0.0.1:41927
    Thu Sep 17 12:10:24 2009 Peer Connection Initiated with 127.0.0.1:41927
    Thu Sep 17 12:10:27 2009 Initialization Sequence Completed
    Fatto questo il risultato che mi ritrovo in "Connessioni di rete" lo puoi vedere nell'immagine allegata.

    Qualche idea?

    Grazie mille!
    Immagini allegate

  5. #4
    Baby Droid


    Registrato dal
    Sep 2009
    Messaggi
    5

    Ringraziamenti
    0
    Ringraziato 0 volte in 0 Posts
    Predefinito

    Problema risolto!!

    Non mi ero accorto che alla macchina virtuale installata sul mio pc avevo assegnato esattamente lo stesso indirizzo IP.

    Cambiato indirizzo è partito subito come una bomba!!!

    BYE!!

  6. #5
    Senior Droid L'avatar di micio


    Registrato dal
    Jun 2009
    Località
    Roma
    Messaggi
    392

    Ringraziamenti
    7
    Ringraziato 23 volte in 14 Posts
    Predefinito

    a me invece da questo errore...

    codice:
    Mon Sep 28 12:40:29 2009 OpenVPN 2.1_beta7 Win32-MinGW [SSL] [LZO2] built on Nov
     12 2005
    Mon Sep 28 12:40:29 2009 IMPORTANT: OpenVPN's default port number is now 1194, b
    ased on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earl
    ier used 5000 as the default port.
    Mon Sep 28 12:40:29 2009 WARNING: --ping should normally be used with --ping-res
    tart or --ping-exit
    Mon Sep 28 12:40:29 2009 ******* WARNING *******: all encryption and authenticat
    ion features disabled -- all data will be tunnelled as cleartext
    Mon Sep 28 12:40:29 2009 TAP-WIN32 device [Connessione alla rete locale (LAN) 3]
     opened: \\.\Global\{BE0CC87F-27CF-4B54-B9CB-450F220D3C98}.tap
    Mon Sep 28 12:40:29 2009 Notified TAP-Win32 driver to set a DHCP IP/netmask of 1
    92.168.56.2/255.255.255.252 on interface {BE0CC87F-27CF-4B54-B9CB-450F220D3C98}
    [DHCP-serv: 192.168.56.1, lease-time: 31536000]
    Mon Sep 28 12:40:29 2009 Successful ARP Flush on interface [4] {BE0CC87F-27CF-4B
    54-B9CB-450F220D3C98}
    Mon Sep 28 12:40:29 2009 UDPv4 link local (bound): [undef]:1194
    Mon Sep 28 12:40:29 2009 UDPv4 link remote: 127.0.0.1:41927
    Mon Sep 28 12:40:29 2009 read UDPv4: Connection reset by peer (WSAECONNRESET) (c
    ode=10054)
    Mon Sep 28 12:40:39 2009 read UDPv4: Connection reset by peer (WSAECONNRESET) (c
    ode=10054)
    Mon Sep 28 12:40:39 2009 read UDPv4: Connection reset by peer (WSAECONNRESET) (c
    ode=10054)
    Mon Sep 28 12:40:49 2009 read UDPv4: Connection reset by peer (WSAECONNRESET) (c
    ode=10054)
    Mon Sep 28 12:40:49 2009 read UDPv4: Connection reset by peer (WSAECONNRESET) (c
    ode=10054)
    Il file di configurazione è lo stesso riportato nel post sopra (l'ho copiato da là)
    la vesione di openvpn è openvpn-2.1_beta7-gui-1.0.3-install.

    Suggerimenti??

    grazie!!!

  7. #6
    Baby Droid


    Registrato dal
    Sep 2009
    Messaggi
    5

    Ringraziamenti
    0
    Ringraziato 0 volte in 0 Posts
    Predefinito

    di seguito riporto il file di configurazione sicuramente funzionante

    dev tun

    remote 127.0.0.1 41927 tcp-client
    ifconfig 192.168.56.2 192.168.56.1
    route 0.0.0.0 128.0.0.0
    route 128.0.0.0 128.0.0.0
    #socket-flags TCP_NODELAY
    #keepalive 10 30
    ping 10
    dhcp-option DNS 192.168.56.1

    route-method exe
    route-delay 2
    Le ultime due righe servono solamente per Vista. Verifica che il range di indirizzi impostati per la VPN non siano utilizzati da altri programmi.

Discussioni simili

  1. [NO ROOT][USB TETHERING] Azilink
    Da elegos nel forum Le Applicazioni per Android
    Risposte: 26
    Ultimo messaggio: 14-06-11, 13:02
  2. Configurare VPN con certificato CRT
    Da ouendano85 nel forum HTC Tattoo
    Risposte: 2
    Ultimo messaggio: 04-07-10, 19:28
  3. Configurare mms con TRE
    Da Digit nel forum HTC Dream / Tmobile G1
    Risposte: 4
    Ultimo messaggio: 12-03-10, 18:09
  4. Azilink e Ubuntu. Aiutooo
    Da krusty nel forum Android Tips and Tricks
    Risposte: 5
    Ultimo messaggio: 28-12-09, 01:09
  5. Configurare DNS alternativi, no pubblicità
    Da corrado66 nel forum HTC Dream / Tmobile G1
    Risposte: 0
    Ultimo messaggio: 03-06-09, 14:26

Permessi di invio

  • Non puoi inserire discussioni
  • Non puoi inserire risposte
  • Non puoi inserire allegati
  • Non puoi modificare i tuoi messaggi
  •  
Torna su
Privacy Policy